News & Announcements

Read and discuss official updates here

Game Update 1.53.5 - Release Notes

CATANFionaCATANFiona Administrator Posts: 418 Admin

Greetings Explorers,

Here are the release notes for app version 1.53.5:

Some big things for CATAN – World Explorers today! In the spirit of Niantic’s mission to get our players playing safely out in the real world, we’ve launched a set of big features to gather friends and take your harvesting and building to a whole new level!

First, our new Fabled Harvest gameplay feature allows you to gather friends together and meet up for the chance to unlock great benefits for both you and your team. Throw dice together in real time in a race against the clock. If you win, you unlock Fabled building cards, rare and powerful new buildings you’ve never seen before, worth big Victory Points. Look for the floating balloon at Settlements to find them!

To help coordinate these Fabled Harvests, we’re rolling out over the next few days Niantic Chat, a huge improvement to chat to allow you to create and keep private chat groups for your local Explorers and friends. Share your chat group invite code to bring in any number of Explorers into your different chat groups.

Lastly, we’ve added a day/night cycle to the game, which we hope further immerses you into the CATAN – World Explorers universe!

Thank you to all players in the CATAN – World Explorers community for continually highlighting major bugs, below are some that we were able to fix in this release! 

Bug Fixes:

-The CATAN – World Explorers Team

«1

Comments

  • HuXHuX Member Posts: 2 ✭✭
    edited July 9


  • FillokGraininFillokGrainin Member Posts: 15 ✭✭
    edited July 9

    Refering friend (trade) fix...

    • names are in chaotoc order, with no option of sorting at all?
    • other friends on top
    • with "just" 134 of 400! possible friends and laggy scrolling...

    Ridiculous...


  • SlowfeetSlowfeet Member Posts: 17 ✭✭
    edited July 9

    Game locked for upgrading i Denmark. The upgrading hangs i Playstore.

  • HejmdalHejmdal Member Posts: 10 ✭✭

    It's even worse, I get "This app isn't compatible with your phone anymore" now.

    So I guess that this is the “So long and thanks for all the fish” moment...

  • SlowfeetSlowfeet Member Posts: 17 ✭✭

    Game updated via playstore directly. Now updated and loaded.

  • TheCombobulatorTheCombobulator Member Posts: 152 ✭✭✭

    App crashes even more frequently in the friend list and while trading.

    Friend list keeps changing order.

    Dice games don't allow you to throw dice to the side any more.

    Several times getting stuck in my personal settlement. All the normal icons from the world screen are shown (when they shouldn't be) and the exit settlement button (when you can get it to show below the backpack) does nothing.

    Lots of pretty graphics updates, though!

  • CataniusCatanius Member Posts: 239 ✭✭✭

    Minigames are unplayable... Physics have been changed and it's awful

  • SlowfeetSlowfeet Member Posts: 17 ✭✭

    The Dice game rotate on Android, Are now moved to the far left or right corner of the screen (Samsug S21 Ultra) and can be tricky to aktivate.

  • CataniusCatanius Member Posts: 239 ✭✭✭

    New fabled feature cannot be played in solo but many (nearly all) players can't play it with other players

  • CataniusCatanius Member Posts: 239 ✭✭✭

    100 gold for a try is too expensive. Why not offer a free play per day like in pogo?

  • GrogyanGrogyan Member Posts: 609 ✭✭✭✭

    Literally no one asked for this feature.


    But we have asked for roads and such for actual strategic gameplay.

  • HejmdalHejmdal Member Posts: 10 ✭✭

    It's even worse, I get "This app isn't compatible with your phone anymore" now.

    So I guess that this is the “So long and thanks for all the fish” moment...


  • GrogyanGrogyan Member Posts: 609 ✭✭✭✭
    edited July 9

    @CATANFiona 1.53 appears to not show anyone who is a current friend


    Thus no gifts

  • FillokGraininFillokGrainin Member Posts: 15 ✭✭

    @Grogyan i made them show...but in a way that can't be intended

    • open friend list
    • this will "load" and show "other friends" first
    • scrolling down until you finaly get to the last of "other" (laggy/long load times in between)
    • then get back to top (long scrolls again)
    • by then active friends are loading "on top" of the list.....

    @CATANFiona is it really meant to be this way? (order of friends shown not following any pattern at all in addition..)

  • xBibziexxBibziex Member Posts: 2

    Oh my goodness, SO annoying, unable to open the game and when it prompts you to update I get an erro that says the app is not available in my country (Australia)

    Really been enjoying this game, but the trade not working for over a week now, and now this - means my streak will be broken because what is the chances of getting this fixed today?!

  • JpomJpom Member Posts: 8 ✭✭

    I'm in Australia and was able to download the latest update and trade with friends - thanks! The first thing I noticed was a beautiful sunrise 😍

  • QuacksquaredQuacksquared Member Posts: 3 ✭✭

    I can’t see my catan friends unless I scroll to the bottom of my other friends list and I have 395 friends, this is impossible

  • Suzyau66Suzyau66 Member Posts: 24 ✭✭

    I also can not see friends unless i scroll to the end of invite friends list and then scoll all the way back to the top. Very time consuming.

  • xBibziexxBibziex Member Posts: 2

    It seems to be working now! Thank you 🙏🏻

  • GrogyanGrogyan Member Posts: 609 ✭✭✭✭

    @FillokGrainin it still is incredibly slow, over 2 minutes every time to just load up the friends list regardless if on wifi or 5G

  • DiskolydiaDiskolydia Member Posts: 10 ✭✭

    My Catan friends are gone?? I see other friends from PoGo that I can invite. I have 227, and then I read in this thread that they are at the bottom, but every time I try to scroll all the way to the bottom game crashes and reloads. Not happy :-(

    Also, everytime I have entered something whether a settlement or a center, the world map is zoomed out more than when I entered - that's so annoying. Before the update it was the opposite - being all zoomed in. Both ate horrible - can you make it so that it's just set at the same zoom that I made? :-/

    And a 100 coins for entering the event. **** no. I have not been able to get local community players to play. Maybe in the near future you could make a feature so that one was able to add new friends from settlement's Council? That would be awesome! It would give locals a chance to get new local friends. (I've tried a couple of times to write in the local chat, but with no success)

  • DreadRushDreadRush Member Posts: 1

    I am in Australia and when I click update, it tells me the game isn’t available in my region. This is terrible.

  • BekahBBladeBekahBBlade Member Posts: 1 ✭✭

    In Australia, friends list is broken, and trade still doesn't work. Got sent a gift that couldn't open, sent a gift, and their end just says 'waiting for trade to complete'.

    Friends list needs a grouping and 'minimise' option for 'invite friends'. I have to scroll down a massive list that takes ages to refresh in order to scroll back up to even see my active friends.

    I'm not going to buy massive amounts of gold just to be able to play fabled harvest (as well as needing insane amounts of gold for my golden settlement) - particularly when there aren't many people in my area who play! Community features like that rely on lots of players.

  • danastredanastre Member Posts: 3 ✭✭

    I’m in Australia, I’ve updated and still can’t trade with friends. Clicked on the box a friend had sent me and sent my own to “complete” trade and the box sent to me disappeared and left my box as pending???

  • DiskolydiaDiskolydia Member Posts: 10 ✭✭

    @CATANFiona

    Who came up with the idea of making an update on a Friday, and just leave us all hanging over the weekend? JEEZ!

    Fix the severe game problems:

    Friend List:

    (Unable to see Catan Friends unless all Niantic Friends are scrolled to the bottom / Massive and constant crashes after finally scrolling all the way down and up again / Problems with trades when the above finally worked, so that it seems as if you cannot complete a trade only send. If it doesn't crash that is)

    Dice game:

    (Unable to throw to the sides. It's like it hits an invisible wall like when throwing a dice in a settlement so that it doesn't fall out of the circle / Often problems with the graphic ie. I had a Personal Settlement Brick Tile in the middle of my dice game)

    Map zoom:

    (When you set a zoom and then enter a settlement, resource center or totem it will be all zoomed out afterwards instead of just being set at the zoom before entering anything)


    I haven't even begun "raiding" and by what I read in here, I am pretty sure I'm not going to . It's too expensive and way to difficult to find that many players in beta version and local community. At least here in Denmark my region, an area of Copenhagen.

    I really hope you can make a quick fix on some of these problems, so we don't have to wait until next week. It would be a shame if we had to quit playing because of such and idio tic update.

    /Diskolydia

  • SlowfeetSlowfeet Member Posts: 17 ✭✭

    The dice game is allmost impossible in this update. The surface of the gameboard is too slippery. The dices just slips off the board when rolled.

    The fabled harvests, are way to expensive. In Aarhus region Denmark, the game is just not played by enough players, to justify such a high prize and high demands of explores to complete the harvest. Maybe this feature is just introduced too early. We are "betatesters" for you right now, not your moneybags.

    The game hangs when entering personel setlement and restart of the game is needed

  • TahalnyouTahalnyou Member Posts: 143 ✭✭✭

    @FillokGrainin

    Oh, I have to try.

    Because for the moment my Catan friends have disappeared ...


  • CasQ22CasQ22 Member Posts: 7 ✭✭
    edited July 12

    I am getting an “upgrade to continue” message in the app and when I click okay it takes me to the App Store and says “app not available”. I’m located in Australia.


    Moderator Note: Removed ads by cropping the screenshot.

  • DiabolicalClayDiabolicalClay Member Posts: 14 ✭✭
    edited July 12

    I got around this bug by updating Catan in the AppStore and not from within the app. Hope it helps someone else.

    Moderator Note: Removed ads by cropping the screenshot.

Sign In or Register to comment.