Report a Bug

Share issues that you've found in the game

Game appears to lose sync

DrElectroDrElectro Member Posts: 15 ✭✭

I have noticed that the game loses sync whilst playing.

Specifically I have seem the resource card inventory fail to update when actions that should affect the inventory are taken, this includes spending cards to grow settlements, trading cards either at a settlement or with Catanians, or earning resources.

Additionally I have seen the "daily recap" appear more than once per day, and messages that have previously been read appear unread in the inbox.


A restart always resolves the issue.

The issue can occur multiple times over a 2-3 hour period of play and does not seem related to change of IP address (moving from WiFi to cellular).

Playing on Oppo Find X2 pro running Android 10, in Australia.

18 votes

Bug: Investigating · Last Updated

A fix was introduced in the 1.20.1 build. Additional occurrences are being investigated. Ticket #12984

«1

Comments

  • AngAng Member Posts: 2 ✭✭

    I’ve collect several lumber this morning and should have at least three lumber cards but it’s not showing

  • AngAng Member Posts: 2 ✭✭

    Have uninstalled and reinstalled app and resources are now correct.

  • B4dB4d Member Posts: 5 ✭✭

    I had this issue twice today (that I noticed), what I got in dice mini game didn't show in inventory until I closed and reopened the app.

  • GrogyanGrogyan Member Posts: 265 ✭✭✭

    Device: Galaxy S9+

    OS: Android 10

    App: 1.6.4


    When picking up Resources from Resource Centers (and from Settlements/Personal Settlements), the number of available cards does not always sync properly, such that to Trade or Grow a Settlement means that you often have to restart the game every time to know if the resources that you just attained become visible in both your Inventory and Trade windows correctly.


    Was hoping this would have been fixed for 1.6.4, but it did not.

  • DoraDora Member Posts: 255 ✭✭✭

    Additionally to this, sometimes we don’t get them at all. Seems to have become much worse in 1.6.4.

    I’m playing on both iPhone X and OPPO X2 Lite.

  • SkindogSkindog Member Posts: 106 ✭✭✭

    Similarly, if you have dev cards and spend them to build something, after using thrm it tells you that you have the number you had before you used them.

  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭

    Can confirm this as well; I have had 5 Settlement Upgrade cards - played them all, upgraded the settlement and then I can play 5 more cards again. Game is smart enough at this point not to actually upgrade the settlement.

    Pixel 3a, Android 10, 1.6.4

  • GrogyanGrogyan Member Posts: 265 ✭✭✭

    App: 1.10

    Mobile: Galaxy S9+

    OS: Android 10


    1)

    A few of us went around the other night.

    We noticed that there is significant lag between what the other player has done showing up in your scanner.

    Varies from 10 to 20s


    2)

    But also loading nearby assets taking over a minute to load


    3)

    When several of us were interacting with the same wayspot, it would take several seconds (and multiple screen taps) for that wayspot, such a Resource Center to note that we are there trying to get the resources

  • CoelacanthMakiCoelacanthMaki Member Posts: 15 ✭✭

    I've noticed this happening multiple times every day, if playing for a reasonable period of time.

    When the game appears to "lose sync," I believe I've had quests that require harvesting resources not update during this game state, too.

    In terms of force closing and restarting Catan, the "missing" resource cards appeared, but I believe I observed the quest didn't progress as expected.

  • SSSputnikSSSputnik Member Posts: 14 ✭✭

    Noticed heavily today, walk in resource rich area. Was on 0 for some items. Walking around, it never increased despite me chasing those resources.

    Eventually restarted client and BOOM full to the brim.

    Also seems to lose synch on timers for resource stops, harvests and misc other things like resource point burnout resets.

    IE, the client seems to have major synch issues. This is in urban area with full fast 4G connection on Samsung 10.

  • SSSputnikSSSputnik Member Posts: 14 ✭✭

    Yes sometimes I need to restart the client 4+ times an hour to get it to stay in synch.

  • WillingKiwiWillingKiwi Member Posts: 2 ✭✭

    An having this happen quite often myself too, numerous times a day. Everywhere from resource card counts to playing and crafting cards in the settlement screen to Gilda's daily recap appearing multiple times per day. Probably one of the most frustrating and reoccurring bugs I'm encountering. At least it doesn't take too long to force restart the game which always fixes the issue.

  • YeeHarrYeeHarr Member Posts: 5 ✭✭

    Same for me. I've been clearing my data/cache which is a pain because I have to re-sign in. Based on this thread's comments I'll force stop instead.

  • CataniusCatanius Member Posts: 172 ✭✭✭

    This is not a problem. Game is better with that feature.

  • TwollerTwoller Member Posts: 0

    Hi there, my local and closest resource seems to be broken. It never refreshes.

    Could you please take a look?

    Spielplatz Lorenallee


    Thank you!


    Simon

  • AjanHukkaAjanHukka Member Posts: 320 ✭✭✭
    edited October 2020

    Not so frequent reports about this on the forum recently. Also some people in Discord said that they haven’t encountered this for a while now.

    Is this fixed? Was there a server side update that addressed this?

  • GrogyanGrogyan Member Posts: 265 ✭✭✭

    @AjanHukka @CATANAndrew the new version dropped today shows that the syncing of resources is still not fixed

  • miiichaelmiiichael Member Posts: 1

    Two examples just from today.

  • AjanHukkaAjanHukka Member Posts: 320 ✭✭✭

    If this has no easy solution you should just implement simple ”force resync” button. That was in Ingress redacted and it solved so many problems so often. 😊

  • GrogyanGrogyan Member Posts: 265 ✭✭✭

    @CATANFiona still not fixed, encountered this today in the new season 8

    Galaxy S9+

  • CoffeeAddictMelCoffeeAddictMel Member Posts: 23 ✭✭
    edited November 2020

    Yep, still happening to me too. Also affects the personal settlement. I placed 4 crane cards towards upgrading it & needed to restart to have them appear.

    Post edited by CoffeeAddictMel on
  • AjanHukkaAjanHukka Member Posts: 320 ✭✭✭

    Have you tried a clean reinstall of the game? @Grogyan, @CoffeeAddictMel

    Also, how did it happen? Can it possibly be because real connection problems?

  • GrogyanGrogyan Member Posts: 265 ✭✭✭

    @AjanHukka you should never have to reinstall a game for an update. I have tried on previous updates, and it has made no difference.


    It is not a connection issue, strong 4G, Ingress and other games have no issues.

  • CharmqCharmq Member Posts: 110 ✭✭✭

    @CATANFiona we’re told to upvote issues we have but the problem is when they are marked as resolved but its not and we can no longer upvote it. Today i got a sync issue while getting resources to build at the settlement via dice game. Restarting app solved the problem but its not a viable option if u r doing so in totem mode coz u lose token for that.

  • CATANRaeCATANRae Administrator Posts: 13 Admin
    edited November 2020

    Hi Explorers!

    The test team was able to confirm a number of desync issues were fixed in the 1.20.1 update. However, it appears there are scenarios that require additional attention and I've reopened the investigation.

    If you are encountering this issue, please upvote the thread and leave a comment about your most recent experience with this issue. Some beneficial information for tracking this issue down would be:

    • The time of day that the issue occurred
    • What version of the app you are playing on
    • Which operating system your device is running (Android 10, iOS 13, etc.)
    • Which event occurred which did not update promptly. (Placed a building at a Community Settlement, won resources in a dice toss minigame, made a trade with Gilda, etc.)

    Thank you!

    Post edited by CATANRae on
  • CoffeeAddictMelCoffeeAddictMel Member Posts: 23 ✭✭

    The issue I described above (de sync in personal settlement) occurred in the afternoon on Wed 18/11 my time (Australian eastern daylight savings time), can’t remember the exact time. I am on iPhone X with iOS 14.2, game version is 1.20.1. At the time I was on stable high speed wifi internet

    And no, I haven’t tried uninstalling and reinstalling but tbh really shouldn’t need to

  • AjanHukkaAjanHukka Member Posts: 320 ✭✭✭

    @CATANRae, didn’t happen to me but an other player was able to reproduce the sync issue by losing connection for a moment after which collected resources didn’t update until restart.

    Couldn’t we just have that ”force resync” button? 😅

  • CATANRaeCATANRae Administrator Posts: 13 Admin
    edited November 2020

    @AjanHukka That's good to know! We're tracking desync issues caused by poor network connections in a different ticket. I think both desync issues may be related but any data relevant to the experience will help me and my test team narrow down the issue. A "force resync" button might fix a couple of visible errors but I'd prefer to learn what is breaking, why it's breaking, and prevent it from breaking in the future!

    @Grogyan and @CoffeeAddictMel are correct: a player should never have to clear the app cache or reinstall an app for it to be functional. However, if someone has cleared their app cache or reinstalling the app and that fixed the problem: that's a big datapoint! When I test a feature or investigate a bug, I reinstall several versions of the app several times a day -- if clearing the app cache or reinstalling the app fixes the issue, that may very well be why it I've had a difficult time reproducing it!

    At the moment though, I think it would be more beneficial to know an approximate timestamp of the error and the action that failed.

  • CoffeeAddictMelCoffeeAddictMel Member Posts: 23 ✭✭

    @CATANRae I have just had this happen to me again now (10.35am ADST, Friday 20 Nov), on iPhone X with iOS 14.2, on stable high speed wifi, game version 1.20.1.

    I was in a settlement using totem mode. Placed one set of RC to grow the settlement and it required one more wheat to place another set so I used the trade feature then placed the second set to complete the tile. The screen showed it as successful (ore tile, can't remember the number) but when I went to build on the tile, the tile showed as still needing 1 more set of RC, though the RC has still been taken from my stash. Restarting the game made the RC numbers correct, but of course now I have wasted a totem credit. Very frustrating.

  • HejmdalHejmdal Member Posts: 5 ✭✭

    Also had this happen to me on 1.20.1 (Android) while doing a series of minigames, but at least this is way better than the previous version that required constant restarts to get the resources into sync.

Sign In or Register to comment.