Report a Bug

Share issues that you've found in the game

Daily Rewards (Hard) - Completed but unclaimable

DireDesireDireDesire Member Posts: 3 ✭✭

Prompt for daily recap / rewards appears after 00:00 local time. Tracker for the hard quest remains active, but the quest disappears from the list, and is not claimable even after completion (see image below).

Workaround: change clock timer to before 12am to claim rewards.

4
4 votes

Bug: Resolved · Last Updated

This issue was resolved in the 1.16.6 release. Bug #13067

Comments

  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭
    edited October 2020

    This has been reported before, but I just wanted to re-address its visabily with an issue that is tied into what is reported in the other bug.

    I've been trying for days/weeks to get the Daily Gilda quest - most days I get the message that I have already completed and this happens no matter what time of the day I attempt.

    Late night (10/8) I was configuring a new phone with Catan. Around 11pm, I again checked the Gilda quest and was surprised that it didn't tell me I had already completed. I choose the Easy Quest (Roll 3 Dice at Settlements) and knew I could do it in the morning.

    Come this morning (11/8), the quest was gone from my quest list

    At the second settlement visit of the morning I was able to capture a screenshot of the task "Play 3 Dice"

    So the task is not visible in my quest menu but it is actually doing something in the background.

    On my third visit to a settlement, the number of notifications went up and the number of completed quests went from 2 to 3. However the quest still isn't showing. As soon as I left the quest screen, the number of notifications dropped by 1.

    In approx 45 minutes, it will be 9am so I will post a follow up of what happens.

    Post edited by CATANGarfield on
  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭

    EDIT: App version 1.34

    Pixel 3a, Android 10

    Just updating to 1.6.4 as I type

  • DoraDora Member Posts: 255 ✭✭✭

    I’ve had this once or twice. Usually when I pick it up before 9am. The most recent time for me was season 3 day 1 when I was checking before 9am to see if the bug was fixed.

    If you pick it up at 11pm you can’t then get it again until after 10pm the following day. If it’s sitting there at 11pm just ignore it until after 9am the next day and it should work fine then.

  • KaixuanKaixuan Member Posts: 7 ✭✭

    I also get this if I check the daily recap before 9am. It's happened every time so far.

  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭

    Updated to app version 1.6.4

    No change (8.55am)

  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭

    9.10am; The quest has disappeared and the number of "completed" quests matches (even though they are Friend Quests and can't be completed until I find the NPC again)

  • CATANFionaCATANFiona Administrator Posts: 344 Admin

    Hi,

    Thanks for reporting this issue. We are still trying to identify what is causing it.

    The time of day when the game resets was semi-recently changed to 5am (as opposed to 9am). Could this be where the confusion is coming from? For example, you should see the following if you accept a Gilda quest:

    If are able to accept a Gilda quest, can you please post a screenshot of the same screen so we can check to see if it surfaces correctly? Also, if the 5am reset time does not seem to be the cause of the issue, please let us know.

    Thanks!

    Fiona

  • SkindogSkindog Member Posts: 108 ✭✭✭

    Above is a screenshot I took last night before completing the quest (before 12am).

    And here's another at 3am. Surely the daily recap shouldn't be selectable again at 3am if the task usually runs until 5am?

    If not completed before 12am, the quest has been disappearing from my quest list, and the daily recap button popping up as above.

    Accepting a new quest has only worked if I ignore that daily recap button until after 9am. Selecting it from 12.00-8.59am has always resulted in the "Already claimed" error.

    Playing on Galaxy S9.

  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭

    @CATANfiona My issue was prior to the change of time; I included all the screenshots I had, so I don't have one where it said to collect before 9am.

    Since the change of season and the change of time (to 5am), I have not encountered this problem again

  • DoraDora Member Posts: 255 ✭✭✭

    @Skindog I tried it today and got the daily quest at 7.15am with no issues.

  • fiyahflashfiyahflash Member Posts: 287 ✭✭✭

    I forgot about the quest on Saturday and claimed it around 7pm (went for the auto reward); then claimed on Sunday around 9am and claimed Monday just after 6am. The change to 5am seems to have solved many of the issues with the Daily Quest.

  • CATANFionaCATANFiona Administrator Posts: 344 Admin

    Thanks for confirming that a lot of the issues seem to have been resolved with the change to 5am.


    @Skindog It's interesting that you got the Daily Recap icon at 3am if the reset happens at 5am. We will look into it!

  • MaxxiMinMaxxiMin Member Posts: 1 ✭✭

    My days in the game (version 1.10.1) start at 05:00. When I accept the daily quest it states "Complete before 5am tomorrow!". Today, I accepted the quest around noon. It was still in my list of quests around 21:00 but at 00:55 it was gone even though I hadn't yet completed it.

  • MaxxiMinMaxxiMin Member Posts: 1 ✭✭

    It turns out that the quest is still there but in a hidden form. I could complete it and I got a notification about its completion. See the screenshot that indicates one quest was completed but no quest to claim is listed.


  • MilekMilek Member Posts: 2 ✭✭

    daily rewards says you have till 5 am to

    complete. Except it’s impossible to click complete after midnight as the quest disappears from your quests. See picture showing 2 quest notifications with only 1 visible quest.


    i complete my daily quest most days after work between 1am and 4am and don’t get any benefit from doing so.

  • AvalonAvalon Member Posts: 0 ✭✭

    The quest from Gilda says that you have to complete it before 5 am. However, at midnight, the quest disappears if not completed.

  • SkindogSkindog Member Posts: 108 ✭✭✭

    The 'toast' continues to pop up showing progress towards the quest if you continue to collect brick until 5am (so you can theoretically still complete it). But even if you complete it you can't collect the rewards for it.

  • HondatoHondato Member Posts: 5 ✭✭

    Bump, having this issue too. Hope this can be fixed, or standardised daily reward deadline to 12am instead of 5am to prevent this bug.

    Don't want to adjust my clock just because of this.

  • CATANFionaCATANFiona Administrator Posts: 344 Admin

    @DireDesire Thanks for reporting. To clarify, the hard quest from the day before remains active after midnight?

  • CoelacanthMakiCoelacanthMaki Member Posts: 17 ✭✭

    Hello, this happened to me yesterday, too. I did some relatively unconventional tactics in order to meet the Wheat requirement of the Hard Daily Task.

    Combined with the bug in the inventory not remaining in sync, this issue was made worse by having to expend an unnecessary totem token in order to re-enter a settlement to complete trades for which I had earned the resources.

    The task said "Completed" as a popup notification, but didn't appear on my Quests list to claim rewards.

    I restarted the app a few times in futile hope that I could claim the rewards.

    No dice. :( Very infuriating

  • beaverybeavery Member Posts: 2 ✭✭

    This happened to me yesterday also! I hadn't really read through other players bugs reports to see that midnight is the cutoff 😢😭 I finished my hard task at 12:07am and no matter how many times I restarted the app, I was unable to collect my rewards even with the little 1 showing on the quest icons

  • SkoskoSkosko Member Posts: 0 ✭✭
    edited October 2020

    I pressed daily recap once it was available, but it said it was too early for me to claim rewards and quest. After this I could not see the daily quest. However I still gained progress towards it. The book at the base page also shows a '1' but there is nothing to claim when I press it.

  • KReaturezKReaturez Member Posts: 3 ✭✭

    I'm a singapore player (GMT+8). Gilda's daily quest stops working after midnight, even though it says complete before 5am.

    The quest disappears. And I can't complete it.

    And the notification for daily recap appears, though it says it's too early to collect.

  • CharmqCharmq Member Posts: 183 ✭✭✭

    @CATANFiona hi there! Highlighting this issue coz it says bug fixed on 23rd but still facing this issue. There was no quest today (25th)

  • CharmqCharmq Member Posts: 183 ✭✭✭

    Similar to above post. Daily recap appears after midnight, press it and it says too early. So i tried again at 6am. It “accepts” it but disappears. Not in my quest list.

    It usually appears between the friendship quest and normal quests but its not here today.

  • CeliCeli Member Posts: 1

    I am also having this problem, after midnight when I go to collect reward it says "too early to collect" I attached screenshot. Then when I click Next and select a hard challenge it says I can't because (I forget, something about already collecting the reward? But I haven't? It says it in the screenshot. Anyway it says above that the issues been resolved but this happened today (at 12:30am btw just it case it didn't capture my time).


    Thanks for reading!

Sign In or Register to comment.