Report a Bug

Share issues that you've found in the game

Building removement bug in golden settlement

SchnuefuSchnuefu Member Posts: 253 ✭✭✭

I think this is kinda important... If you want to remove a building in the golden settlement you can't by clicking on "remove". You have to click "cancel" for it to be removed... come on guys... get it together...

45 votes

Bug: Resolved · Last Updated

This issue was resolved in the 1.27 release. Bug #14207



  • beaverybeavery Member Posts: 2 ✭✭

    Hi, I just placed a second card onto my personal settlement (costing 250 gold) and it accepted, then both cards got out back into my inventory? I've replaced level 1 at another cost of the initial 50 gold. Can I please either have a reimbursement of the 300 gold that was wasted, or the cards placed back into my settlement?

  • SchnuefuSchnuefu Member Posts: 253 ✭✭✭

    HTC U12, Android 9.x, Catan Worldexplorers first 1.16.6 then upgraded to 1.20.1

    The reason for this bug is, that there was an update without an announcement. You changed the rewards from 150 each ressource to 150 random ressource. The game didn't update on itself and because it is a new attribute, it didn't give any ressource on my roll today. Why did you nerf this...? Just because it's the most powerful card? It is even more frustrating, because I just recently updated it to level two and, now that this card is ****, I wanted to remove it and place another building, but it won't let me...

    Building could be removed.

  • AjanHukkaAjanHukka Member Posts: 448 ✭✭✭
    edited November 2020

    There were reports on other forums that:

    Remove cancels

    Cancel removes

    A pretty small but bad bug indeed. 🙈

  • MynoraMynora Member Posts: 1

    Effectivement, quand on clique sur "annuler" pour sortir du menu de "déménagement ", cela retire le bâtiment comme si on avait cliqué sur "supprimer". J'ai perdu ainsi 300 gold,ce qui représente presque 3 jours de jeu, car cela a retiré un bâtiment qui était déjà niveau 2.... Maintenant je n'ai pas assez de gold pour le remettre, c'est rageant !

  • usbusb Member Posts: 1 ✭✭

    I'm here because I was trying that button, saw what it did so I pressed cancel. it took the building away. Not sure what happened, tried it again and it took another building away. Looks like two developers were involved, the functional bit in iOS (ok the left button) and the graphics in Android (ok the right button).

    Now I lost two buildings gold. How do I get it back?

  • BennywomplerBennywompler Member Posts: 9 ✭✭

    Same problem here, lost buildings on cancel button. Expect to see bugs in a beta, but when those bugs cost us real money, how about some compensation credits?? @CATANfiona

  • PHOTOXPHOTOX Member Posts: 36 ✭✭

    Hi @CATANFiona ,

    I had this bug too, so lost the gold involved in building up 2 buildings to level 3 :(

    how do we get this back?

  • sophie298sophie298 Member Posts: 1 ✭✭

    I experienced the same issue, it removed two buildings :/ Can we get the gold back please?

  • EBcNEBcN Member Posts: 1 ✭✭

    Same issue for me, only lost one building but with gold being so rare it’s still a significant loss... If I could get the gold back it would be greatly appreciated thanks

  • ShazzadoomShazzadoom Member Posts: 14 ✭✭

    Agree with all the above. Depending on how long this has been an issue, I also think removing buildings should incorporate a lot more forgiveness. Being able to undo a deletion or an extra popup before deletion would prevent much grief. I deleted buildings before without realising what was involved and lost a lot of gold this way too.

    I agree that some sort of compensation credit would be appropriate.

  • PringlePringle Member Posts: 1 ✭✭

    Yeah same here, lost a building because of it. Would really like to be able to get that gold back.

  • AnonFatCatAnonFatCat Member Posts: 1 ✭✭

    Same, wasn't easy getting 100 gold...I clicked the bag button to see what it did, and though I pressed cancel, it bagged it...and I was stupid enough to do it twice

  • SchnuefuSchnuefu Member Posts: 253 ✭✭✭

    @AnonFatCat nothing to do with stupid ;) it's something you wouldn't expect at all so the first time you didn't realize what happened, because it's unbelievable. Only at the second time it's possible to realize what happened in form of confirmation :)

  • Scarecrow275Scarecrow275 Member Posts: 1

    Yeah I have lost 100 gold because of this bug. :(

    The cancel button removed my building and I was like "what the" and then it did it again when I tried again.

  • AjanHukkaAjanHukka Member Posts: 448 ✭✭✭
    edited November 2020

    This is second reason in addition to the nerf why you should now reset everybodys golden settlements and refund them all the gold they have spent on it till that day.

    People could just rebuild it the same if they want or build it a new based on the new changed mechanics. @CATANdominik

  • S7iCkSt3RS7iCkSt3R Member Posts: 5 ✭✭

    I've also encountered this issue. Accidentally clicked on the remove building button, then clicked cancel. Building was removed. I was confused and thought I clicked the wrong button, so I tried it again. Same thing happened, so I've lost two buildings and don't have enough gold to place them again.

  • TBANGTBANG Member Posts: 1

    Just stumbled across removing buildings by accident. Clicked cancel. Building removed anyway. Thought I made a mistake so I had a look at another building. Pressed cancel again. Building gone. Are we getting our gold back for this?

  • ANGRYtelleANGRYtelle Member Posts: 1

    This also happened to me! Would love a way to get my gold back as it takes a bit of effort to collect.

  • Furtie94Furtie94 Member Posts: 1

    I had this same issue, clicked on the remove button, was shown cancel or remove, clicked cancel then the building was removed. After the building was removed I wanted to check to make sure I did actually click cancel, went back in and hit cancel then building was removed. I would like my coins added back into my account for this.

  • TrocarTrocar Member Posts: 6 ✭✭

    I was trying to move buildings on Golden Settlement

    1. Clicked on grand treasury, CANCELLED move, but it REMOVED it anyway! (Thanks, that big cost 250 gold!)

    2. Clicked on weaver, DID THE SAME!

    2. Trying to move Archives, it REFUSES to remove building!

    So now I'm out a LOAD of gold, and the building I want to move is stuck!

  • cdragoncdragon Member Posts: 1 ✭✭

    I accidentally clicked the remove button on a building in my gold settlement, which prompted the warning to cancel or continue.

    I also clicked cancel and it removed my building anyway as well. It was only a 50 gold building, however I'm also out of coins.

  • MadonelleMadonelle Member Posts: 0 ✭✭

    When I looked at removing a building from the golden settlement I hit cancel because I was curious how it worked. This button removed the building. The remove button works as the cancel button and does not remove the building. Not pleased as gold is hard to earn.

  • FeythyerFeythyer Member Posts: 9 ✭✭

    Can we get an update on this please? How do I get my 250 gold back?

  • Shogun79Shogun79 Member Posts: 12 ✭✭

    I just lost 100 gold.

    I just started with golden settlement and pressed on cancel, and building got removed, I thought I saw not correctly and tried again and second building was gone...

  • AB8891AB8891 Member Posts: 1

    Just lost 100 gold due to this bug. Clicked cancel and i was like ****. Went to the other clicked remove and it cancelled. Unsure if i clicked the wrong thing looked at it again and clicked cancel and it removed my other placed card. Be nice if it gets fixed soon i uist started playing

  • TrocarTrocar Member Posts: 6 ✭✭

    It just refuses to be dissolved. Indeed as I was clicking other building accede tally were returned.

  • RyutRyut Member Posts: 4 ✭✭

    This is ridiculous. I just lost a lot of gold because I clicked cancel. How can such a major error not be fixed yet after it'sbeen reported for so long?

  • ZanduBalmZanduBalm Member Posts: 1

    Same thing happened to me, lost 100 gold in total when pressing cancel instead of remove. Tried it twice thinking I had pressed something wrong. I wish to get the gold back as I had spent real money buying gold to place the golden settlement.

  • SchnuefuSchnuefu Member Posts: 253 ✭✭✭

    @Trocar did you try pressing "cancel" instead of "remove". The buttons are mixed up...

Sign In or Register to comment.