Report a Bug

Share issues that you've found in the game

Cranes do not drop dev cards

GrogyanGrogyan Member Posts: 332 ✭✭✭

App: 1.20.1

Device: Galaxy S9+

OS: Android 10


@CATANFiona

At settlements with Cranes and Staple Houses, when you collect rewards for tiles which have Cranes or Staple Houses, the Development Cards do not drop when using the "Harvest All" button

Collecting Development Cards with the manual "Collect" button does work


Same occurs with Golden Settlements and Personal Settlements

10
12 votes

Bug: Resolved · Last Updated

This issue was resolved in the 1.33.2 release. Bug #14799

Comments

  • StellalanderStellalander Member Posts: 1 ✭✭

    Hi there. I crafted a crane in my personal settlement. When I went to place it, it along with the resources paid was not anywhere to be found. This seem to have coincided with me going up a level.

  • JervisJervis Member Posts: 2

    I had a similar problem. I gave 1 upgrade card for crane in personal settlement. The graphics showed success but then it dropped back to 0 cards and returned the crane development card.

    I retried and same happened.

    3rd attempt and it took the development card but crane still didn’t accept the card, shows 0.

  • SchnuefuSchnuefu Member Posts: 247 ✭✭✭

    @Grogyan first I wasn't sure but now that you mentioned it I focused on it and I can confirm this, but it's not the harvest all button actually. Harvest all works but you need to wait for the animation to finish before clicking "collect rewards". if you click "collect rewards" before the animation of crane and staple house finsished, you won't get the development cards

  • WeissWeiss Member Posts: 14 ✭✭

    @Schnuefu so you mean to say that we need to go through the action of harvesting each and every resource we get in the settlement dice game in order to get the card?!?! 🤯

  • SchnuefuSchnuefu Member Posts: 247 ✭✭✭

    @Weiss no only click harvest all and let the animation go through before you click collect

  • LysaraBlackwoodLysaraBlackwood Member Posts: 57 ✭✭✭

    It didn't work for me if I waited for the animation to finish on harvest all. The cards appeared in the animation but not in my inventory.

  • WeissWeiss Member Posts: 14 ✭✭

    @Schnuefu Thank you got the information. Will see if it works for me.

  • SchnuefuSchnuefu Member Posts: 247 ✭✭✭

    @LysaraBlackwood ok that's weird... were your bags maybe full?

  • RedbirdRedbird Member Posts: 26 ✭✭
    edited January 8

    The crane placed in personnal settlment drops never a card.

    Post edited by CATANGray on
  • SchnuefuSchnuefu Member Posts: 247 ✭✭✭

    Did you already reboot?

  • RedbirdRedbird Member Posts: 26 ✭✭

    Every day multiple times @Schnuefu

  • SchnuefuSchnuefu Member Posts: 247 ✭✭✭

    on which * did you place it? left or right? I have mine on right and don't have trouble. Also make sure that you don't click "collect rewards" too early. you need to wait until the cards show up on the right of the screen.

  • CATANFionaCATANFiona Administrator Posts: 289 Admin

    Hi - This is the same issue mentioned in this thread: https://community.catanworldexplorers.com/discussion/718/cranes-do-not-drop-dev-cards. We are still investigating the cause of this.

  • RedbirdRedbird Member Posts: 26 ✭✭
    edited January 9

    Little gelp can be in solving this when i roll a 6 (first time this season)😄 it did give me dev cards but never with the *

    @CATANFiona


    And sry did not see the other thread i do not annymore scrollbak 10 sites to search for oldbug reports 🤪

Sign In or Register to comment.