Report a Bug

Share issues that you've found in the game

(1.27) Missing Catanian trade options

WindWind Member Posts: 413 ✭✭✭✭

Am on latest version for my Android, where i interacted with 2 catanians, no trade options are shown.

since all of my Catanians are Great Friends, and if all mine shows up blank, this is a very concerning gamebreaking bug that affect day to day gameplay

i request an urgent fix ....this is frustrating when something fixed, something breaks. Therefore require your attention to this @CATANFiona @CATANdominik



33
33 votes

Bug: Resolved · Last Updated

Bug #15404

Comments

  • WindWind Member Posts: 413 ✭✭✭✭
    edited January 9

    3 more Catanians since the post....all missing the trade options, and yes they are all great friends


    bleh...downgrading the app now..... would be so annoyed if that bug is not fixed in time for the force update.

  • GrowLongDragonGrowLongDragon Member Posts: 12 ✭✭✭
    edited January 9

    Seems to affect Catanians that are Good Friends and above, still possible to trade with Catanians that are Friends and below,

    Post edited by GrowLongDragon on
  • WindWind Member Posts: 413 ✭✭✭✭

    @GrowLongDragon nah it affects all. Even the ones i completed.

  • MykanMykan Member Posts: 54 ✭✭✭

    Also missing trade option on 2 of the 3 catanians I checked today. Last one I checked was Embla who had no trade option

  • OzeagleOzeagle Member Posts: 9 ✭✭

    Same issue here, no trade options. Have only encountered one Catanian since updating.


  • ZinkyZonkZinkyZonk Member Posts: 95 ✭✭✭

    Missing trade options .... andriod s20FE

  • MaebiMaebi Member Posts: 16 ✭✭

    iPhone 12 Pro, update auto-installed to 1.27


  • LysaraBlackwoodLysaraBlackwood Member Posts: 62 ✭✭✭

    I've been able to trade with some Catanians, not others. Here are the ones without trade options.


  • Shogun79Shogun79 Member Posts: 12 ✭✭

    I'm current stuck with the task "Trade practice 2"

    BC with the lasted update, trading option disappeared and I can't finish now the tasks



  • OzeagleOzeagle Member Posts: 9 ✭✭

    Same issue here, no trade options with most Catanians I have encountered. A couple have worked, no pattern to the ones that worked that I could see.

  • WindWind Member Posts: 413 ✭✭✭✭

    @CATANdominik @CATANFiona

    please do something about the gamebreaking bug that affect the day to day gameplay, now we got 17 and counting upvotes.

    many of us would be forever grateful if you guys plan an emergency version update to fix this serious bug.

    thanks in advance

  • MykanMykan Member Posts: 54 ✭✭✭

    Might be some inconsistency to this bug. I had embla yesterday with no trade option but today she has a trade option. Still get plenty of catanians without the option though.

  • AnduAndu Member Posts: 7 ✭✭

    I had this issue but fixed it. I logged out, and logged back in. If you log back in as a returning user , I had an error. So I logged in as a new user, using the same login credentials as my existing account. It stuck on the loving screen. After this I closed the app, with Force Stop ( Samsung s20) and logged in again as a returning user. Everything loaded up okay again. But the I think I lost the chance to claim the hard daily prize. I'm chalking it to beta big testing. So no biggie.

  • MaebiMaebi Member Posts: 16 ✭✭

    iPhone 12 Pro, update auto-installed to 1.27


  • WindWind Member Posts: 413 ✭✭✭✭

    Ok so i had a theory after two observations in the last 24 hours while i wqs out doing my loop - which included the catanian intermission times that usually occurs at 55th to 59th minute of each hour.

    before the intermissions, i noticed catanians did not offer trade options but after, they do. This is why i bring mymipad with the older version just in case i need to do trades (so annoying)

    so just now, imdecided to open my game at 12:55 and wait til the intermission is over, and for the next spawn...it did appears with trade options available.

    restarted my game and his options disappeared from same catanian.

    .....this is just yet another frustration that i do not want to put up with all the time therefore it needs to be fixed asap along with the gilda quesst claiming bug!!!

  • CATANFionaCATANFiona Administrator Posts: 344 Admin

    Hi - Thanks for reporting this issue. We are working on an immediate fix to this issue. I will update the status of the bug on this thread once it is fixed.

  • ExplorerXExplorerX Member Posts: 12 ✭✭

    Same issue, Xperia XZ. Some Catanians have trade options, some don't (see pics)


  • KamikazeDan1KamikazeDan1 Member Posts: 32 ✭✭

    I have had a mix of Catanians I can and can't itrade with. The first one who showed up that i couldn't trade with was my only Aquaintance (Mr "go and collect park tiles" of which I have none in my usual play areas), but I've since had some that were higher levels also with no trade options. I've had both Good and great friends with and without since then.

  • CATANFionaCATANFiona Administrator Posts: 344 Admin

    Hi - We attempted a fix for this. Is anyone still experiencing this issue?

  • WindWind Member Posts: 413 ✭✭✭✭
    edited January 14

    I can see right away on the 1.27.3 (thats on my android) but not the 1.27.2 (thats on my ipad)

    will double check at different hours throughout the day

  • CuddlepieCuddlepie Member Posts: 33 ✭✭

    Issue still present. No trade option on my iPhone (ver 27.2) but interestingly I can see a a trade option from thr same catanian on my ipad!

  • WindWind Member Posts: 413 ✭✭✭✭

    Updated my ipad to 1.27.3 and looks like its fixed.

  • CATANFionaCATANFiona Administrator Posts: 344 Admin

    The fix would be on 1.27.3. Let me know if you are on that build and still see the issue. We are hoping that this is fixed!

  • WindWind Member Posts: 413 ✭✭✭✭

    Can confirm it is fixed on 1.27.3.

Sign In or Register to comment.