Report a Bug

Share issues that you've found in the game

No crane yield from “starred” tiles

AlbaacAlbaac Member Posts: 31 ✭✭

When crane building is located on guaranteed “starred” tile it doesn’t yield a development card. Storehouse and bell tower do yield as per descriptions in the same circumstance.

iPhone 7, version 1.3.4

14 votes

Bug: Investigating · Last Updated

We are investigating this issue. Issue #13759.

«1

Comments

  • LukeyLukey Member Posts: 2 ✭✭

    I have twice attempted from a fully upgraded Crane and received no reward (also no animation). Checked bag inventory after to confirm no yield.

    iPhone 8, 13.6.1

    Attached screenshot to show position (* roll).


  • LukeyLukey Member Posts: 2 ✭✭

    I have twice attempted from a fully upgraded Crane and received no reward (also no animation).

    iPhone 8,

    Attached screenshot to show position (* roll).


  • beaverybeavery Member Posts: 3 ✭✭

    Same for me and my partner. Lucky enough to be able to roll almost every 6 hours. Fully upgraded crane on the * and get nothing from it. Even when rolling adjacent numbers.

  • AlbaacAlbaac Member Posts: 31 ✭✭

    Crane works for me these days in version 1.14.2

  • AjanHukkaAjanHukka Member Posts: 316 ✭✭✭

    @Albaac, so it now works even when it is fully upgraded?

  • AlbaacAlbaac Member Posts: 31 ✭✭

    @AjanHukka will test out at level 5 tomorrow. Have one at level 4 that pays out, didn’t realise it was only an issue at level 5.


  • AlbaacAlbaac Member Posts: 31 ✭✭

    Confirmed no crane yield at lvl 5 today, will be keeping the rest at 4. Still an improvement on no yield at any level in the earlier version.

  • HeffersHeffers Member Posts: 1 ✭✭

    Crane: level 5 on * tile

    Don't receive any Dev cards when I physically go to the settlement and roll, but it worked correctly yesterday (Oct 13) using my totem: rolled an adjacent number, and got 10 Dev cards.

    LG V30+, version 1.14.2

  • FresspapaFresspapa Member Posts: 56 ✭✭

    I've not received any yield from any L5 Crane for a few days now. As soon as they are L5 --> no yield. No matter if I show up in person or via totem. no matter if via * or via number it sits on. Really bummed that I leveld them all up to L5. wish I had kept them at L4

  • PHOTOXPHOTOX Member Posts: 36 ✭✭

    Fully upgraded Crane at 3 different locations. 1 visited with Token.

    On several occasions, Crane has yielded no reward when on * or rolled on attached tile.

  • AjanHukkaAjanHukka Member Posts: 316 ✭✭✭

    There are reports that this bug still happens with 1.16.6. @CATANFiona

    Meaning that there is no yield from lvl 5 crane.

  • DengueeeDengueee Member Posts: 1 ✭✭

    Placed on * with staple house on the other * slot

  • SkindogSkindog Member Posts: 106 ✭✭✭

    Does it make a difference if you claim the rewards from each building individually? I've been trying to test to see if it's a visual error or worse.

  • FiskerKFiskerK Member Posts: 5 ✭✭

    Same Thing is happening to me. No cards are awarded from my fully upgraded crane on one of the settlement. It doesn't help if i claim the rewards individually.

  • FiskerKFiskerK Member Posts: 5 ✭✭

    Today it the same bug was at another settlement also. This was also a lvl 5 crane. I harvested 2 times at each of the two settlement and got no cards at all. Thats 20 cards lost in one day, very frustrating.

  • CATANFionaCATANFiona Administrator Posts: 236 Admin

    Thanks for letting me know this issue is not resolved. I will pass this onto the team and we will investigate.

  • ChopStiRChopStiR Member Posts: 26 ✭✭

    Been having the same issue.

  • Suzyau66Suzyau66 Member Posts: 12 ✭✭

    Mine some times works some times not. If i get two bordering squares only one will pay.

  • Suzyau66Suzyau66 Member Posts: 12 ✭✭


  • AjanHukkaAjanHukka Member Posts: 316 ✭✭✭
    edited October 2020

    @Suzyau66, there were similar reports on forums. So that it’s exactly that star tiles don’t activate it correctly. @CATANFiona, this may be important to note.

  • HaramDingoHaramDingo Member Posts: 2 ✭✭

    I have observed two issues with cranes:

    • Level 5 cranes, regardless of whether they're on a starred tile or a numbered cell do not yield cards at all. So I leave the cranes at Level 4.
    • For cranes Level 4 and under, if I skip ahead of the animation during "Harvest All" before the cards actually come out of the rolled cell, they won't be added to my inventory.

    It's kind of sad, but yeah it's really annoying when you build up your crane level only for the max level not to give you anything. It might just be a mistake.

  • AjanHukkaAjanHukka Member Posts: 316 ✭✭✭

    There was a mention on other forum that this may be fixed now. Anybody able to test it?

  • GaLaReNGaLaReN Member Posts: 12 ✭✭

    Sounds a lot like the library at L5, also doesn't give any RP,only xp

  • Sparky13Sparky13 Member Posts: 2 ✭✭

    I am still unable to receive any dev cards from a level 5 crane located on the star tile this has still not been resolved and has been happening all day in Australia

  • MikeyMikey Member Posts: 35 ✭✭

    This morning, I upgraded a crane on a * tile to L5 and also didn't receive any rewards.

  • TechTech Member Posts: 3 ✭✭

    It seems to work if I claim resources one by one, but doesn't seem to work if I use the collect all button.

  • FiskerKFiskerK Member Posts: 5 ✭✭

    The bug is still there

  • CATANRaeCATANRae Administrator Posts: 13 Admin

    Hi Explorers!

    Thank you for your diligence on this one! The issue for ticket #12850 was that the Crane was silently awarding items (and not showing the animation)!

    There is a new ticket for the issue where rewards are not being granted to level 5 Cranes (issue #13759). Thank you for your patience!

  • AjanHukkaAjanHukka Member Posts: 316 ✭✭✭

    @CATANRae, so as mentioned, public settlement Library has probably this exact same problem too. Does it get fixed on the same go?

Sign In or Register to comment.